Comments

Iomega iConnect solutions? — 23 Comments

  1. I am also regularly getting “device is currently unavailable” and I am a little disappointed in the fact that my external hard drives never spin down forcing me to disconnect them when not in use

  2. In all the time I have been dealing with Iomega, I (nor they) have been able to get this yoke running properly.  As far as I can make out, it is a memory problem in the unit.  When it has been running for a short while (measured in minutes rather than hours) it knocks out its own internal web server which supplies the management interface.  Bloody annoying!

  3. Firstly, I would like to thank you Richard for your help regarding the turning off of the Media Server. This stopped the constant spinning of my hard drives and also stopped the “device is currently unavailable” problem. Unfortunately this means I have to access the Management interface before I am able to access anything using my PS3 or other device, but I can live with that. I have decided to use large capacity usb pen drives as a main storage/torrent downloading destination for the unit as they maximize energy efficiency and most importantly don’t spin when the unit is in Media Server mode. I can attach my hard drives when needed.

    Since using your tip regarding the Media Server, I have not had any problems accessing Management, as you mentioned in your most recent post. Maybe this will occur after more usage but so far it is not knocking out its own internal web server to my knowledge.

    Also just to mention, I downloaded the firmware update from the Iomega web site and was unable to extract the rar file downloaded. I tried multiple times and one from a separate source downloaded via a torrent with no luck.

  4. Since replying to your first comment, I did some more messing around with the unit.  I rebooted it and ran it very successfully for a couple of hours with only one external drive attached.  I thought that maybe it had decided to behave itself, so I plugged in a second drive.  The web interface crashed again!

    As part of my initial attempts to get it running, I downloaded and installed the firmware.  I had no problems with that, and if it’s any consolation, it didn’t make any noticeable difference.

  5. I have the dreaded  “device is currently unavailable” after starting the iConnect up and running succesfully. What is the “Media Server” you refer to and how do I access it to turn it off?

  6. Hi Rob, and apologies for the slow response.

    To deactivate the Media Server, disconnect all USB devices from the iConnect and then re-power it.

    Log into the web interface as Admin.

    Click on the Settings tab.

    Click on Media Services..

    Click on Media Server.

    Deselect ‘Enable Media Server’ checkbox.

    That’s it.

  7. I’ve had my iConnect one day, and have run into the same problem with the web server dying. I guessed that the Media Server might be the problem, but even after disabling it the web server still dies. One solution is just to reboot the device; another is possibly to restart the embedded appweb sever (I haven’t tried this yet) using the ssh access.
    Any update from Iomega on a fix for the flakey web server?
    That said, I love the device – it’s an inexpensive print server  for my USB laser printer, the PTP server works great for saving my photos off my camera, and in general it does everything I really bought it for.

  8. Hi Jeffrey.  I have been onto Iomega quite a few times since i wrote this.  I have never managed to correct the web server  failure, and I have an additional problem in that it fails to recognise one of my external drives.  Iomega seem to have given up on my problem (even though the web access is obviously a common one)  and each time they just say that my problem “has been forwarded to the engineers”.

    Like yourself, I am carrying on using the iConnect.  I can’t access it but at least I can see two external drives that do work in it, so it is partially doing its job.

  9. With apologies for the delay in replying – I wanted to try out a couple of things first.

    I tried reformatting the drive in question.  That was no mean feat as I had to back up a Terrabyte of data (it’s a 2Tb drive) which took a while.  I then tried reformatting it in various ways and even tried partitioning it and using dual format.  Nothing worked and the iConnect blankly refused to recognise that the drive even existed.  It’s back to NTFS now and working perfectly as it is plugged directly into my laptop.

    Every time I contacted iConnect in the past they always trot out the “incorrect format” thing so at least that one is put to bed!

  10. Hi – I’ve had the same issues.  Not getting anywhere with support – so after 12 frustrating months – anyone interested in a second hand (never worked) Iconnect in warranty?  Opting for an LG NAS with DVDRW waiting on its arrival – if it does what it says it can it will be fab and good value for money.  Shame on Iomega for continuing to sell a product that is clearly riddled with problems!

  11. Firstly thanks for the advice on this I am currently giving this a go, my thoughts on why this work are that with the media server switched on it probably does a regular scan of all your drives, as my 4 drives add up to about 2TB this is no mean task, and I believe the messages displayed on the error page all hint at time out or server busy scenarios
    Anyway a further tip I have collected was to put a static IP address in the network setting . I use .99 on the end of the IP and this may help also as it does not need to to any sort of DNS look up
    I would also recommend switching off any facilities you don’t use , email notification and print server were to I zapped. I get the impression this little device that has the potential to be a great gadget can’t cope with too many things at once which is a great shame as there is very little else on the meerkat with the same potential

  12. I have a strong feeling that the capacity of the drives does have a bearing. 

    When I initially bought mine I tried it with the Media Server set to off, but it still failed to see one drive (a 2Tb) and although it would see the second drive (also a 2Tb) it would fall over shortly after.  It does however work perfectly with a 1Tb drive connected.

    As I used to work as a Network Administrator, I have a habit of setting all devices to a fixed IP!

    I agree that it has a great potential as a device and that there is nothing similar on the market.  Unfortunately it has failed in my hope to have a centralised network storage and is now relegated to acting purely as a Media Server for my 1Tb drive, which I feel is a terrible waste.

  13. I'm completely happy with this device, because…It runs debian 6.0.6 (squeeze)!!!http://www.congenio.de/infos/iconnect.html. I've got the device for a couple of days now. The first thing I did, was to get rid of the base installation. I plugged in a hard drive, with the raw image of congenio installed, followed the instructions on their site. And now, I've got three devices connected. Running a samba server, mediatomb, transmission-daemon, ntop, i.e., I basically have the same functionality as the box itself, but completely stable. Also, I'm running my webserver on the device. All in all, a complete, quite fast, debian system with only 5 to 8 Watts of power consumption (8 with three usb powered harddrives)

    • Apologies for the delay in replying!  😉

      I tried the fix you mention.  I installed the download and apart from having some fun resetting the IP address [what made them chose 192.168.168.168?!] it seems to run all right.  However at this stage, I can ping and FTP into it but as yet haven't been able to see the device or the attached drives on the network.  More work to be done…….

  14. Hi All, 

    I am new to this forum, so sorry if i am re-posting this question. 

    I recently purchased at Iomega Iconnect Wireless data station. Connected and works perfectly within my wired network. Two WD hard disks are currently connected. The 500GB hard disk is being shared perfectly. 

    The 2TB HDD has been detected and shows the correct available space. But shows that there is no data on the device. The hard has been checked on two different computers and works fine. 

    Can anyone help!

    • First of all, this isn't really a forum – there's just me.  😉

      Since I first got my iConnect I have kept a fairly close eye on complaints and there seems to be one common factor – the iConnect apparently has great trouble connecting with any drive over 1Tb in size.  I have a 1Tb drive running perfectly off mine, but it just refuses to work with either of two other drives which are both 2Tb.  One of those drives causes it to crash and the other just won't connect at all.

      So that seems to be the answer – if you want to connect 1Tb (or less) drives than that's fine, but if your drives are bigger then forget it.

  15. hello Richard;Is it still working with you; or only work for 74 hours then stopped.I bought iconnect iomega 2 years ago, and yesterday I spent the whole day working with it, everytime it was disconnected and show (the dvice is currently unavaliable).I follow everything on the net, disabled media service as you said, disable user and secure managment … the same results.I updated the firmware tp 2.5.26 and updated the mac client to the latest ..Can you please advice.

    • Hi Majdi.  Mine is still working but only with the one external hard-drive plugged in.  It has been working quietly for the last couple of years and I haven't dared to touch it!  Apart from the various hints and tips I have already posted, I'm sorry but I can't help.  Iomega aren't much more helpful!

  16.  Here isa bit of a left field suggestion ditch your iomega and buy a raspberry pi , with a little but of effort you can turn it into a headless machine which you can access remotely, you can control bit torrents and newsgroups   

  17. Meant to add I have had this solution up and running for about 5 months now, with little or no trouble, unlike the quirks you get with Iomega, though I still have this plugged inWith a 1 Tb external drive connected, and space for three more, it works very well, iI can even access the network share from my WD tv box, streaming my dowloads direct to the telly.Additionally I can transfer dowloads direct to my IPad 

  18. Installed my iConnect today with 4 external HDDs 1 TB each.My Mac is seeing all of them but are all recognized as 192 MB drives.  PLus i cant see the previous data in any of them. Will try formatting one…..   Have no idea whats wrong ?  🙁

Leave a Reply

Your email address will not be published. Required fields are marked *