Comments

Installing Adobe Air on a 64-bit Linux Mint — 42 Comments

  1. Thank you, thank you, thank you
    This is so sweeeet.. works like a charm, and a learned so much from this tutorial. Thanks again.
    Greetings from Saudi Arabia

  2. Fabulous. Works perfectly. Thank you so much for posting this.
    Oh how I’ve missed TweetDeck….. aaahhhhhh  🙂

  3. Man, I wish I had found your post first. I’ve been following all sorts of tutorials, messing with .bin files and –force-architecture and such, and now I’ve ended up with a system that gives me the following error no matter which .deb version I try to install:
    dpkg: error processing adobeair64.deb (–install):
     adobeair: 1:2.6.0.19140 (Multi-Arch: no) is not co-installable with adobeair:i386 1:2.6.0.19140 (Multi-Arch: no) which is currently installed
    If anyone has any ideas how to get around this, I’d love to hear it! Thanks!
     

  4. @Mike,  I’m a bit of a newcomer to Linux and a bit grey in years so I take  the simplest route where possible.  I always search for a solution that involves as little command line stuff as possible.  I saw some of those solutions, and ran!

    It appears that somehow you have managed to install adobeair:i386, or part of it, so the first thing I would try is to remove that?

  5. Looks to be a great guide – however I can’t seem to find the deb file anywhere. Can someone mirror it for me??

    many thanks
    Bryan 

  6. Welcome Bryan!

    Apparently they have discontinued it…

    I’m not sure of the copyright issues here, but here is a version I cooked some time ago.  It’s oldish, but works.  Let me know how you get on.

    P.S. It’s 19.5Mb in size!

  7. Your adobeair fix worked very well for Mint-11 (64 bit), but I have not so far had any luck with Ubuntu 11.4.  (I used your old deb file.)  Can you think of any reason for that?  Could you make it work on Mint-12?  This last is my real interest.)   Thank you very much for your work on this problem!

  8. To be honest, I never tried it in Ubuntu, though I am surprised it didn’t work.  It worked perfectly in Mint 12, which is what I am using now.  I just used the standard method – Right click on the file and select “Open With GDebi Package Installer”.

  9. OK, I will try install Mint 12 and try it.  Just to be clear, should I install your adobeair_64.deb file that I downloaded or should I first follow your steps to modify the control files, etc. ?  

  10. Using the file on the site here should be fine (I think Adobe have removed all Linux versions anyway).  It was this file I used when upgrading to Mint 12, and as I said – it worked fine here.

    Good luck, and let me know how it goes!

  11. I tired this several ways, with your deb file and with an i386 file that I had from a while ago.  No luck.  AIR gets installed, but when I run it I get the error:
    Failed to execute child process “/usr/bin/Adobe AIR Application Installer” (no such file or directory)
    The file is actually there, but I can’t execute it from a terminal.
    (I used synoptic to uninstall AIR between attempts.)
    Somehow I made this work in MINT 11, but not in 12.  Any ideas?

  12. Ouch!  I tried installing it again on this machine but it complained that there was a more up to date version already installed.  Using Synaptic I then uninstalled Air.  That went without a hitch.  I then tried installing adobeair_64.deb file using GDebi.  Again, no problems. 

    I notice that Adobe Air doesn’t appear on my menus, even if I do a search.  However, I tried selecting TweetDeck_0_37.5.air and it asked if I wanted to install it using Adobe Air Application Installer.  Once again, that ran perfectly and Tweetdeck (God help us!) is now installed.

    I am honestly at a loss as to why it doesn’t work on your setup.  Is it possible that it just doesn’t like being called from a terminal?  Have you tried installing a .air source file [i.e. TweetDeck.ver.air]?

  13. At last, I fount the solution! On this site http://www.jamesward.com/2010/10/14/install-adobe-air-on-64-bit-ubuntu-10-10/
    there was the suggestion in one of the comments to try this:
    sudo apt-get install ia32-libs
    This made sense to me because of the emphasis of 32 bit libraries in some of Adoe’s earlier published workarounds and also because I didn’t have a lib32 in / after the initial Mint 12 installation! Once I had lib32, installing your file adobeair_64.deb worked fine. Thanks very much, Richard, for your help. BTW, what was your experience with respect to lib32?

  14. Nice detective work!  Yes, I do have ia32-libs installed.  I can only assume that something else I installed loaded them as dependencies, though I fon’t know what.  Air is usually at the bottom of the list of stuff I load, as I only use it for Tweetdeck, and I’m not a great fan of Twitter!

  15. I just tried this and there is no .deb file for Adobe Air any longer. They pulled support for Linux altogether. There’s old AdobeAirinstaller.bin downloads available on the Air Archives page, the latest being 2.6, but I don’t have a clue as to how to modify your procedure for that. Any ideas or am I missing something?

  16. If you look down the replies, I stuck a note up on Novenber the 21st that contains a link to the DEB file I use.  It is a little out of date but it works (and will update itself later).  It works every time for me anyway.

    Ah feckit – here’s the link again!

  17. It worked! Thank you so much for this. You definitively saved me from a huge headache. And I learnt a lot from that how-to as well 🙂 
    Cheers from Belgium, Marianne.

  18. You’re welcome! One month later, I’ve just installed the recent Mint 13 RC and… a fleeting panic, how do I get Adobe AIR back again ?! but… there you are, saving me again 😀 (This time, I’m saving everything on my external hard drive). Anyway, thanks again 😉

  19. You’re welcome again!!

    Incidentally, I just installed Mint 13 [MATE] myself, and I notice a load of programmes won’t run on it [yet?], including the likes of Tweetdeck, which was my only reason for installing Air in the first place.  Tomorrow I may try out the Cinnamon version to see how that works.  So much fun and so little time!  😀

  20. Pingback: Running Tweetdeck on Linux Mint 13 MATE | A Pipe and a Keyboard

  21. Why isn’t it working for me. It shows up in my applications menu, but not the /usr/bin. I click the menu item and it says it doesn’t exist. “No such file or directory”. Is it some place else??

  22. @Andrea. Sorry for the delay (again) but for my own curiosity I downloaded 10 and installed it, and then installed Adobe Air.  It seemed to install OK.

    The actual installed location is /opt/Adobe AIR (having followed various links to reach it).  Try looking there!

  23. @Andrea.  Once I had a problem with a missing lib32 folder.  (See my post of Dec 12, 20011.)  Do you have that folder where Adobe can find it?  I hope this helps.

  24. My lib32 folder is in /usr. I went to the december 2011 section of your blog and there are three articles and none mentions that file. Could not find in search. What do I need to do to make it work?

  25. Okay, but I still can’t get the program to work. This iss reall friustating. I hate the new Tweetdeck so bad. It was the only program that allowed you to thaank and follow your followers and now I can’t use it. I tried executing the program from /opt and nothing happened.

  26. I DID IT!! I only needed to install ia32-libs and it worked perfectly. I have installed Tweetdeck on my 64 bit desktop and I didn’t even have to login or change anything, because I always backup and transfer everything when I install a new OS.
    Thank you!

  27. Great stuff!!  Reading through the comments, Angus Lawson had suggested the ia32-libs fix but I neglected to read my own site!  There is a lesson there somewhere?

Leave a Reply

Your email address will not be published. Required fields are marked *