Running Tweetdeck on Linux Mint 13 MATE

I am not one of Twitter’s greatest fans.  However I do have a couple of accounts and occasionally I like to keep an eye on them.

My Twitter interface of choice is Tweetdeck, and for the last while I have been having some problems.  My original problem was that Tweetdeck requires Adobe Air, but Adobe don’t support Air for Linux any more.  I eventually sorted that one out and life was quiet for a while.

Six months ago I started using MATE as my desktop of preference and once again I ran into problems with Tweetdeck.  It refused to work on MATE but was quite happy if I logged in using Gnome.  I posted a query on this on the Mint Forums and the reply was that Tweetdeck only runs on Gnome or KDE.

I like challenges and can be quite stubborn when it comes to sorting little problems.  I have upgraded to Mint 13 MATE version and my challenge was to get Tweetdeck running as a normal application.

I decided that one way to do it would be to run Tweetdeck in Windows 7, running in VirtualBox.  I already had the latter set up so I installed Tweetdeck and tried to log in.  No go.  Possibly there was some way or fixing that, but I didn’t fancy firing up VirtualBox just to see a few Tweets anyway.

My next idea was to install Wine and to install Tweetdeck using that.  Success at last.

Tweetdeck was now running very nicely, but I had a new problem – I had to drill down to “/home/user/.wine/drive_c/Program Files (x86)/Twitter/TweetDeck” to run the programme.  Painful!  I decided to add it as an Application in my Menu.  The command I used was “wine /home/user/.wine/drive_c/Program Files (x86)/Twitter/TweetDeck/TweetDeck.exe”.  That failed.  It reported that there were files it couldn’t find.  So obviously it had to be run from within the Wine drive.

The solution is simplicity itself.

I created a small shell script that would be run by my Menu entry….

cd “/home/user/.wine/drive_c/Program Files (x86)/Twitter/TweetDeck”
wine TweetDeck.exe

I saved it as “TweetDeck.sh” in my Home folder (and of course made it executable) and ran that as an Application from my Menu.

Problem solved.


Comments

Running Tweetdeck on Linux Mint 13 MATE — 4 Comments

  1. As you know I got Adobe Air installed but never got Twhirl to work.  I ended up going with a native program called Turpial.  It’s down and dirty and very easy to use so I’m happy for now.  Someday I’ll go back and work further on getting Twhirl to work but for now I’m happy with Turpial.
     

  2. Hi there!
    Thanks for sharing you experience with tweetdeck. I’ve got question about Adobe AIR. Today I installed on my PC Linux Mint 13 Mate 1.2. Awesome, but one little problem. I tried install Adobe AIR 2.6 (last supported for Linux), after running bin file I get error about missing keyring. Ok, now I have all those libraries but still no luck. Have you experienced similar problem?

  3. The only problem involving keyrings was when I tried installing Tweetdeck.  The failure to run on MATE is, I suspect a problem with the said keyrings. 

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>