Comments

Using Remote Desktop in Mint 13 Maya — 21 Comments

  1. Just a quick thanks for this nugget of info. Really really useful. Just to clarify however something that is not entirely clear unless you copy and paste is that the command  usr/lib/vino/vino-server –sm-disable has a double dash before sm not a single one. Once i’d worked that out – all was good. Cheers



  2. My pleasure!  Thanks for pointing out about the double dash.  Judging by the traffic to this page, a lot of people are having the same problem.

  3. Would you please explain some options on using the last Maya login option, Secure Remote Session?
    All it shows me is a box prompting host and port.  I can find zero information about which protocol it would be using or what I would need server-wise on my home/work network
     
    cheery bye
     
     

  4. Installing xrdp allows you to remote desktop from windows machine without going through difficult settings. If that is what you are looking for…

  5. Thanks, Liton.  My problem was that I connected to two other Linux Mint machines from my laptop.  It worked perfectly until I updated the lot to 13 Maya.  I installed Vinagre on this machine but couldn’t fire up the VNC server on the other machines as it was no longer available.  Hence my fix above.

  6. You, my friend, deserve a beer. This just ended about an hour of irritation, and has delayed my plans to roof-test this Linux box.

    • Beer always welcome!

      I just hope this problem is fixed in 14 when it comes out. Judging by the hits on just this page, Remote Desktop seems to be a major omission.

  7. I just installed Mint 14 and can't get this to work. I can set preferences but when I enter vino-server –sm-disable it just says command not found. Any idea what I'm doing wrong? (I am in /usr/lib/vino when I try it.)

    • They seem to have reinstated Remote Desktop in 14 so the above instructions are redundant.  Just go to Preferences -> Decktop Sharing, and away you go!

  8. Thanks Richard. However, I don't have a "Preferences" in my menu. The closest thing I can find is "Settings", but there is no "Desktop Sharing" there or anywhere else in the menus that I can find. Is that because I have the XFCE 4 desktop environment?

    • With apologies for the delay (it takes a while to download and install XFCE!)

      Try goiing to Settings -> Session and Startup.  Select "Application Dutostart".  Towards the bottom of the list, you'll find "Desktop Sharing (Gnome Destop Sharing Server)".  Select that and you should be OK.

      Let me know how you get on.

  9. I've tried the Settings -> Session and Startup, Application Autostart and checked the "Desktop Sharing (Gnome Desktop Sharing Server)" and rebooted. However, no luck. I've tried connecting from two different Windows machines, using TightVNC and UltraVNC, on a home network (everybody can ping everybody else). All I get from the viewers is "failed to connect to server".

  10. Thousands of Thanks !!! Works great on Mint 14 Nadia :)Don't forget the double dash() in usr/lib/vino/vino-server sm-disableand it'll be perfect.You really saved my day ! Thanks again 😀

Leave a Reply

Your email address will not be published. Required fields are marked *