Install Google Earth with photos on Linux Mint 18 (64bit) — 52 Comments

  1. Oh Wow!  Thank you so much for this – it worked perfectly for me on a clean SSD install of LM18 Sarah Cinnamon 64bit.  I had already installed GE from Google's own website, and found that it works, although it occasionally starts then instantly crashes as it tries to zoom in.  A simple repeat seems to bring it up again OK.   I have not had a reliable GoogleEarth for longer than I care to admit, and the Panaramio images have never worked for me since I came to LM.

      • No, it wasn't you.  I managed to screw up my own computer (messing with SSD settings) and have now had to re-install LM18.  Having done all that, I find that lsb-core is no longer available.  [code]Package lsb-core is not available, but is referred to by another package.
        This may mean that the package is missing, has been obsoleted, or
        is only available from another source

        E: Package 'lsb-core' has no installation candidate[/code]



        • I just did a quick check (not wanting to mess up anything I just did "sudo apt-get install lsb-core".  It replied –

          Reading package lists… Done
          Building dependency tree      
          Reading state information… Done
          lsb-core is already the newest version (9.20160110ubuntu0.2).
          0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.

          I would assume from that that it found the package and checked it against the already installed one?  Maybe the repositary was unavailable when you tried?

          • Hi Richard.  It seems my previous reply to you never made it through the ether.  I am now having serious problems with my LM18 Sarah which seem to be centred around either the SSD or your GoogleEarth Panaramio fix.  I'm not yet sure which, and I'm running temporarily on a single used HD only to see what breaks it.

            However, yes my repository mirrors were defective (chosen for speed of connection), and once I linked to some more reliable mirrors the lsb-core loaded fine, as did some other dependencies and apps that had also failed.   The others on here who agree that it works for LM18 Cinnamon have reassured me it is a problem with MY system, not your code.  Do you believe that your script should be compatible with an SSD?  I keep getting corrupt disks that LM18 constantly tries to check, and refuses to boot, but I don't know why because the disks are fine if I load another system and then mount the disk.

  2. This works great but it leads to a puzzling question:  I tried to do the same thing the script does, manually, by downloading amirpli's original updated qt libraries as found via a link on the Google Products Forum (four files in the ,/opt/google/earth/free/ directory and two in the subdirectory /plugins/imageformats/), and googleearth crashed like crazy.  Now I install via your script and it works like a charm.  The only differences I can think of are: 1.  the qt libraries have been updated further; or 2.  I should have installed libfreeimage3 at the end of the process, like your script does, rather than at the beginning, like I did.  Pretty sure I had the file permission set correctly.

    Enquiring minds want to know!  🙂

    But in any case, many thanks for getting it right.

    • My pleasure!  I had to run several trial runs before getting it all to work, and I did find some peculiarities – installing stuff has to be done in the right sequence, presumably because a later package uninstalls and earlier one. 

      I remember in the past I had a problem with uninstalls.  Either installing Google Earth uninstalled Wine or it was the other way around.  I can't remember now.

  3. Worked fine for me…After " sudo apt-get install lsb-core -y -f " I was able to install via gdebi package installer…Your script worked fine and i can now see photos on google earth…Thank you! 

  4. This seemed to work perfectly and without any issues on my newly minted Mint 18 setup. You need not have worried about wrecking this system. It gets "wrecked" with reasonable frequency as I use it for experimenting and teaching, and have more than one full disk image backup for "disaster" recovery.

    • I always feel a need to use that caveat, just in case someone screws up their system by mistyping something and then blaming me for their error!

      One of the great joys of Linux is the ease of reinstalling (provided you have a backup of /home).  Windows on the other hand………….!

      • Or better yet, when you create the system, always put /home in it's own partition.  That allows you to reload the system without having to restore /home from a backup (which you should keep current anyway)….just remember that when installing and it comes to the partitioning, always take 'something else' for the option, then reformat the / folder, then keep and use the  existing /home without formatting.  


  5. I just installed LM18.1 Serena (Mate) and used your advice to install Google Earth. Worked great! First time in years I have had access to pics on GE. Many thanks to you!

  6. I just want to say thank you for making this available. I have just upgraded (fresh install) to Linux Mint 18.1 and followed your instructions. Worked perfectly! I am one happy camper! This is an excellent Google Earth experience.

  7. $ sudo dpkg -i google-earth-stable_current_amd64.deb
    [sudo] password for jimmy:                                                                
    dpkg: error processing archive google-earth-stable_current_amd64.deb (–install):          
     cannot access archive: No such file or directory                                          
    Errors were encountered while processing:                                                    

  8. Have tried for years to get this to run properly in Linux Mint. – Just installed Mint 18.1 (Serena, 64 bit, mate flavour). – Found this & for the first time in the last 3 years, Google Earth even displays all the photographs. — Absolutely Fabulous!!!! Thank you ever so much.

  9. Thank you very much, it works perfect om my laptop with Mint 18.1 KDE. On my desktop I am running Mint 17.3 KDE, do you think it will work on that one as well? I was installing GE 32bit on my desktop but pictures do not work, only a blank white square.

    • The fix uses 64-bit libraries so I doubt very much if it'll work on 32-bit!  That's why I specifically mentioned 64-bit in the title.

  10. OK, I will uninstall my 32bit GE and follow your instructions to see if it works on my desktop with Mint 17.1KDE.

  11. I have just heard, via the Linux Mint forums, that Google have been making G.E. to run only on Google Chrome, which I have long hated.   Just hope this site can keep G.E. running under Firefox as long as possible.

  12. After much frustration at other websites, this procedure worked so well it seemed too easy.  How beautiful!  Thanks a ton.  Mint Serena Mate 64-bit.

    One suggestion:  It'd help people like me to be told how to get in the Downloads directory before running the command.

    • I think I may have had that problem myself in the past.  If I remember correctly it was something to do with the sequence in which I loaded the various bits.  Try uninstalling and reinstalling?

  13. Running fine on my 18.1 to 18.2 upgraded PC. But on my laptop which was working on 18.1 fine,it is a no-go.Even resorted back to 18.1 to try again but it didnt work,whereas it did before.?? 🙁

  14. Does there need to be an adjustment in the code typed if google earth pro was installed? I’m getting the same hangup as Richard Holland when installing on 18.2.

  15. Rats. — Just recently installed new version of Linux Mint 18.2 (64 bit, MATE version) & no more Google Earth. – Can’t seem to get it back.

  16. Worked perfektly- Thanks. Photos were available without the script.Linux Mint 18.2 Cinnamon 64Bit, AMD FX8350 8 core, Nvidia MSI GeForce GT 710 2GB

  17. Thanks for the great work. However, I am still having problems. GE loads, gets a big loading image in the middle but all of things are happening in a small window in upper left corner. So I am sure that your script did what it was supposed to, it is my system just not cooperating with GE or vice versa. I am using Mint 18.3 Cinnamon but hardware is not to the par (it is 64 bit machine but it is antique with today’s standard :~). Anyway, so I decide to let go and uninstall but unable to. When I try to uninstall from main menu I get “This menu item is not associated to any package. Do you want to remove it from the menu anyway?”  At this point I am not sure how to proceed. Yes, I am a Linux noob.

    Any help would be appreciated.


    • I am no expert myself!   Have you seen the latest post I linked to at the top of this page?  When I installed the latest release I got something like your description – loading image and a partial load in the background.

      When you say you tried to uninstall, did you do that from GE’s menu item or from Software Manager?  In Software Manager, search for “google-earth” not “google earth” and see if you can remove/reinstall from there.

  18. I tried the instructions above wicth went well till I got to download the first link. It cane us as Failed. Object not recognized.


    I want GE on my Linux 17.3 because my windows machine died last night.

    I am still learning Linux. Am standing at the beginning  and staring at the steep slope of the learning curve

    Ed – KB8QEU  –

    • Google Earth has changed considerably since I started posting these “fixes”.  For a start, it no longer displays those old uploaded photographs (which is a shame).

      Try just installing GE from the Software Manager (search for “google-earth”, not “google earth”).  If it fails to run properly (getting stuck half way) then try the link at the very top of this post.

      I think we are all still learning Linux!  I started using it about five or six years ago and have used it exclusively ever since.  I wouldn’t dream of going back to the horror of Windows!  Persevere and you will be well rewarded.


  19. Mint 19, both mate and cinnamon, program loads, you see the entire earth, but then I get a totally black screen with the menu on the left, but the map is only a corner of the upper left. Both Nvidia and Radian cards and plenty of memory….suggestions? (18.3 worked perfectly on both with your info…thanks)

Leave a Reply

Your email address will not be published. Required fields are marked *

HTML tags allowed in your comment: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>