Comments

Google Earth on Linux Mint 18.3 — 14 Comments

  1. I installed on a friend’s machine and had the freeze at the splash screen problem. I tried to follow your instructions but synaptic didn’t find xserver-xorg-video-intel on the computer. Any other suggestions?

    • Sorry, but I can’t help there.  The stuff that appears here is a fix I have discovered (usually after a ton of searching and experimenting) to solve problems on my own setup.  Usually they will work for anyone using Linux Mint (64 bit) but the above is more machine specific.

  2. Yes, my problem with version 7.3.0.3832 (64-bit) in Mint 18.2 beyond the menus that the main earth display being restricted to tiny window in the top left-hand corner. The xserver-xorg-video-intel fix did not work for me.

    The only other fix being to revert to older version 7.1.8.3036 (64-bit) which displays in full.

  3. Having installed this, the problem with using an older version is that the Update Manager wants to update to the newer version. Aside from un-ticking the update box, how does one continue to automatically inhibit the update until a later time, ie. when Mint 19.0 becomes available?

    • I have never tried it before, but the Update Manager has a blacklist – Update Manger -> Edit -> Preferences, and hit the Blacklist tab.  Try entering “google-earth-stable” and by my understanding it will then ignore GE updates.

  4. Yes. It worked ok easily after removing the ‘xserver-xorg-video-intel’ file with Synaptic.

    Thaank you!  🙂

     

  5. I was searching for something, trying to solve my problem with GE and i just had see a guy that talks about your site, where i found this wonderful trick!

    I tried it and it works for me:

    So, it works on 32bit systems to!…

    Thanks.

Leave a Reply

Your email address will not be published. Required fields are marked *