Comments

OpenBVE broken on Linux Mint 17 — 8 Comments

  1. Hi Richard. I have installed Linux Mint 17 V2 and it has the correct libraries, as mentioned in your post, but OpenBVE still will not run.

    • Are the library versions in your install the save versions as the ones above?

      I just checked another machine that has 17 running on it [but no OpenBVE].  The versions there are libgdiplus V2.11 and Libtiff V5.  Both these libraries have to be reinstalled with the older versions to run OpenBVE.

      • Hi Richard. You are absolutely correct. So am I right in thinking that I have to remove the later libraries and replace them with the older? Will that not cause problems with other applications that require the later libraries? It is looking as if I should roll back to Mint 13 as there are so many things I am having problems with in Mint 17. I would have stuck with 15 if I could have because everything worked OOTB (which was the whole reason for me migrating from Ubuntu in the first place).

  2. Thank you. Excellent post! I just apply the modification of the images (png's) from "indexed color" mode to "RGB color" mode from the update section.

  3. Hello Richard. I got your link from 'Headrambles', and, as a novice Linux user have being following this excellent blog.I've followed the instructions as described and am happy to say that my OpenBVE is now working.Thanks…Paddy.

    • Welcome to this little corner, Paddy.  I have been running this for a while, mainly as a notebook for myself (I use it occasionally when I know I solved a problem in the past but can't remember how).  Lately it has become somewhat neglected simply because I haven't had too many problems!

  4. Hello, and thanks a bunch, Richard.

    You saved my day in Rebecca. Exporting those images to RGB worked like a charm.

    Out of curiosity, how'd you precisely pinpoint that only those 2 files were creating problems with libgdiplus? I.e., as a CLI novice, I'd very much like to know the diagnostic procedure that you undertook, since my rudimentary investigation went no further than running openbve in terminal and then looking at the output dumbfoundedly. 😛

     

    • Welcome Mitropam! 

      Essentially, I cheat.  If I come across a problem I search the Internet [mainly forums and websites] to see if there is a fix anywhere.  It means going through dozens of sites and in a lot of cases, no results.  If I do find a solution, I post it here mainly for myself [I use this site a lot for overcoming old problems!] but am aware that others probably have the same problems as myself.

Leave a Reply

Your email address will not be published. Required fields are marked *