Comments

Fixing the unbroken — 6 Comments

  1. Heh, well gee whiz, I wonder who talked you into trying Cinnamon again? By the way, I found out why the Cinnamon nightly builds won’t run properly on a new installation of Maya/Cinnamon, it’s missing a dependency (which has been reported at Github->Mint/Cinnamon).
     
    Attempting to start “cinnamon-settings” called out an error that “lxml.xtree” (sp?) was missing. The solution was to install “python.lxml”. After installation the nightly builds worked fine. The only reason I can figure that my original install of Maya/Cinnamon didn’t have this problem with the nightly builds was that “python.lxml” was already installed as a dependency of one of the third party applications I run like Google Earth or Skype, both of which load a ton of dependencies.

  2. The second paragraph should actually read:

    “Attempting to start “cinnamon-settings” from the terminal called out an error that “lxml.xtree” (sp?) was missing

  3. Oh yeah, I forgot to mention just how I found this out. I downloaded a a new .iso of Maya/Cinnamon and installed it into one of my test partitions. My initial reason was to check if MDM still disappears after a couple of seconds (on boot/reboot) if the Nvidia video driver is installed–it still does. But not in Maya/MATE. But this is another problem that doesn’t affect you.
     
    Once I finished working on the above problem I added the Cinnamon nightly PPA and updated and guess what happened? Same problem as you encountered–no Cinnamon Settings. That’s when I attempted to start “cinnamon-settings” via the terminal, got the call out I mentioned previously, researched the problem and installed “python.lxml”. Problem solved. So, insltall “python.lxml”, add the nightly PPA and update. after update, restart Cinnamon or log off and log back on and everything should be fine.
     
    On the off chance that everything ain’t fine, simply go into “Software Sources” and remove the Cinnamon nightly PPAs then open Synaptic and search for “muffin” and remove all installed “muffin” packages. The search for “cinnamon” and remove do the same (should only be one package). Log out and and log back under “Gnome Classic”. Open Synaptic again, hit the “Reload” button and then search for “cinnamon” and install (it should install the needed “muffin” packages as well). Once finished, log back out, choose “Cinnamon” and log back in again and you’re back to the original Cinnamon “shell” (1.4).

    But you shouldn’t have to revert. Installing “python.lxml” solved the nightly problem very nicely.

  4. Typos I can cope with!

    I took the plunge and added the Nightly PPA.  I did the refresh and it informed me that Cinnamon and Muffin were both to be updated.  It then added (a little apologetically, I thought) that it would need to install “python.lxml” as well.  Do the Cinnamon developers read this blog?!  😉

    All running very smoothly now, and thanks for the hand-hold.

Leave a Reply

Your email address will not be published. Required fields are marked *