Comments

Adventures with Natty — 2 Comments

  1. Oh you brave geek you. I’m duly impressed. A couple things though. The first being that keeping your existing Mint partition as home will probably cause problems since many of the OS’s configuration files are located in the “Home” directory. That plus you’ll be attempting to use a Linux Mint Home directory based on Ubuntu Maverick while installing a whole new version of Ubuntu which will write it’s own configuration files to the same Home directory–it might complain a bit but you’ll be able to talk it into it I’m sure (use a hammer, it works well in such cases). It will probably work after a fashion but you’ll have to do a lot of tweaking and weeding out.
     
    The second thing is if you decide to go with Natty once it’s released I’d wait on the install until Linux Mint 11 is released (early May) and then add the LM 11 repos and keyring to Natty after installation so you can get all the Mint goodies like Skype, Google Earth, sun-java (instead of that horrid open-jdk), etc. All the stuff that Ubuntu doesn’t have. One thing to keep in mind though is LM 11 will be using Gnome 3 without gnome-shell installed (uses the classic Gnome desktop) while Natty still uses Gnome 2.32 with the Unity desktop shell (a Compiz plugin believe it or not) but since LM 11 will be based on Natty there really shouldn’t be a problem. Just watch closely when you update.
     
    Too much info? 😀
     

  2. I would imagine that presented with an existing Home partition, Natty would only overwrite those settings folders that it needed to.  Most of the settings are for software that isn’t part of the OS.  For example, my mail, my Firefox files and my other application files would remain intact.

    I did actually try this out and it worked very well.  I have run Mint since, and none of the settings directories seems to have been affected.

    Copying the software sources into the repository also seems to have worked well, as i now have the full rnage of software available, as far as I can see,  For example, I knstalled Skype and Google Earth and the latter was the only package out of the lot to give any problems – it’s fonts are all wrong and virtually unreadable.  I’m sure that could be fixed though in the settings.  I haven’t tried yet.

Leave a Reply

Your email address will not be published. Required fields are marked *